Back to overview
Downtime

Degraded platform performance

Oct 30, 2025 at 07:54pm UTC
Affected services
Transaction Broker
Website

Resolved
Oct 31, 2025 at 09:16am UTC

Website has fully recovered, the root cause was a misconfigured security group

Updated
Oct 30, 2025 at 10:18pm UTC

Our website is partially online again, however some pages might not work correctly.

Updated
Oct 30, 2025 at 08:02pm UTC

Transaction Broker recovered and is processing all requests again. Our website remains offline for the time being

Updated
Oct 30, 2025 at 08:00pm UTC

Transaction Broker not processing all requests. We are still investigating the root cause

Created
Oct 30, 2025 at 07:54pm UTC

Our website went down, we are investigating the root cause